Page 1 of 1

Can't Update to 9.55

PostPosted: Wed Jul 15, 2015 9:53 am
by JonJohn11
I can't update the humble client to .955, pretty sure this is the same problem I had in .95. Please update it so I can play, Thanks.

Re: Can't Update to 9.55

PostPosted: Wed Jul 15, 2015 2:16 pm
by MrBenjammin
The files are up to date and correct. I've just downloaded it to make sure. It may of been that the files are cached on the CDN that was serving you. I've purged them so they should be up to date. Could you try again?